Welcome to the LimeSurvey Community Forum

Ask the community, share ideas, and connect with other LimeSurvey users!

Error - Sumary jumps back to first question

More
2 years 7 months ago #204417 by Anonymname
Hey,

I made a sumary which randomly chooses one questions from a group of 10 questions. That happens with 12 groups. So in the end the sumary shows 12 randomly chosen questions.
Somtimes it works as it should, but sometimes it jumps back to the first question and I don't know why.
My first group has 10 hidden equation questions with:
First question:
Code: ask1
Question: {floor(rand(1, 10.999))} /that means it chooses one random number from 1-10

Second question:
Code: ask2
Question: {floor(rand(1, 10.999))}
...

Then my first group withe the questions to fill out has 10 questions:
The first question has ask1==1 at the relevance equation /if the random number of ask1==1 the first question will be shown
The second question has ask1==2 at the relevance eqation /if the random number of ask1==2 the second question will be shown
...

As I said sometimes it works perfectly, but sometimes if you have already filled out some questions it jumps back to the first question and I don't know why. Do you know what could be the problem?
Thanks for the answers!
The topic has been locked.
More
2 years 7 months ago #204439 by tpartner
LimeSurvey version?

Have you disabled AJAX in the survey theme options (if available)?

Can you attach a small sample survey containing only the relevant questions?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The topic has been locked.
More
2 years 7 months ago #204441 by Anonymname
Version 3.6.2+180406

I haven't changed anything about the theme, but I don't think AJAX is available.

Thank you for your help.
The topic has been locked.
More
2 years 7 months ago #204447 by tpartner
I asked for a sample survey, not sample groups. Sorry but I'm not going to spend time creating a survey and importing your groups.

I'm fairly sure AJAX was available in 3.6. You will find it in the theme options.


Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The topic has been locked.
More
2 years 7 months ago #204460 by Anonymname
Okay I disabled AJAX now.
Do you want the sample survey in the format I attached the groups or a link?
The topic has been locked.
More
2 years 7 months ago #204465 by tpartner

Anonymname wrote: Okay I disabled AJAX now.

Did that fix the problem?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The topic has been locked.

Lime-years ahead

Online-surveys for every purse and purpose