Two-Factor-Authentication is now live

More
4 months 4 days ago - 4 months 4 days ago #199824 by kjnerhus
Tried in Chrome as well and got the following message in console:

jquery-3.4.1.min.js:2 Uncaught TypeError: Cannot read property 'bind' of undefined
Attachments:
Last edit: 4 months 4 days ago by kjnerhus. Reason: two identical images

Please Log in to join the conversation.

More
4 months 4 days ago #199826 by ollehar
Strange. Can you give me a screenshot of how the browser looks like?

Please Log in to join the conversation.

More
4 months 4 days ago #199827 by kjnerhus
OK here:
Attachments:

Please Log in to join the conversation.

More
4 months 3 days ago #199873 by cdorin
I cannot reproduce the issue - installed successfully the plug-in after the latest update. Could you please create a bug report on bugs.limesurvey.org ? (provide as much information as possible)

Also, make sure the permissions are correctly allocated and that you have unzipped the plugin in the plugins/TwoFactorAdminLogin folder. Thanks for your help! :)

Please Log in to join the conversation.

More
4 months 3 days ago #199880 by cesystra
Hello,
Same issue here.
I can confirm the installation seems to be working.
However unable to register any 2FA for my account.
Nothing happens when I click on "Register 2FA now".
On "Console" view of Firefox I got same error message as kjnerhus.

Please Log in to join the conversation.

More
4 months 2 days ago #199900 by cdorin
Ok, found the issue. I messaged Olle about it (it is about the path where the plugin gets installed if you use the plugin GUI)

Please Log in to join the conversation.

More
4 months 1 day ago #199995 by ollehar
Busy right now, will look at it later. Sorry for the delay.

Please Log in to join the conversation.

More
4 months 19 hours ago #200082 by ollehar
I applied another fix. Please download the latest version from here and let me know if you still have any issues. Thank you.

www.limesurvey.org/limestore/extensionde...administration-login
The following user(s) said Thank You: cesystra, cdorin

Please Log in to join the conversation.

More
4 months 19 hours ago #200084 by cesystra
It works!
Thank you so much.
Regards.

Please Log in to join the conversation.

More
2 months 2 weeks ago #202477 by wedwo
Is 2FA enabled for CE yet?
Thank you!

Please Log in to join the conversation.

More
2 months 2 weeks ago #202556 by cdorin

Please Log in to join the conversation.

More
2 weeks 6 days ago #204932 by mrmartinforster
Hi! I am just a bit confused. We recently started using Limesurvey CE and I missed the fact that the 2FA wasn't available for CE yet. However, our consultant installed it and it works almost perfectly. The only issue is that we need to use Safari or Firefox - when using Chrome after the 2FA-installation we are often unable to edit questions and we get the error message i include at the bottom.

But maybe we should uninstall until it actually is launched for CE?

/Martin

Errors happened during the update check. Please notify the extension authors for support.
TwoFactorAdminLogin: Call to undefined function LimeSurvey\ExtensionInstaller\curl_init()

Please Log in to join the conversation.

More
2 weeks 5 days ago #204939 by cdorin
Hey Martin,
Please open a ticket in our support tracker to have it investigated further (from your limesurvey.org profile).
2FA should work in both LS3 and LS4.
The following user(s) said Thank You: mrmartinforster

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now