Two-Factor-Authentication is now live

More
9 months 2 weeks ago #187736 by jljansen
Hi cdorin thank you for looking in to this :)
I've a self-host instance. Page is now accessible for this user and I can try to connect a 2FA. Response (directCallConfirmKey) unfortunately is
{"success":false,"message":"No permission for this","data":[]}

For the admin user there is no problem with permissions but with
{"success":false,"message":"The confirmation key is not correct.","data":[]}

Tried both Google authenticator and Authy with the same results.

How can I best help troubleshoot this situation?
The following user(s) said Thank You: cdorin

Please Log in to join the conversation.

More
9 months 2 weeks ago #187762 by cdorin
Thanks for the feedback. The developer knows about it. We will soon provide another update.

Please Log in to join the conversation.

More
8 months 3 weeks ago - 8 months 3 weeks ago #188693 by PPRI
Hi. Markus. Nice to meet you in here. I am Young from PPRI.

I tried Limesurvey Professioanl(Hosted Service) and 2FA is working fine in there. I also have a CE Version 3.17.16+190906. I downloaed and installed the plug-in but it's not working.

I clicked 'Create 2FA Binding' after typing in the confirmation Key but nothing happen with both Google Authenticator and Duo.

Any suggestion?
Last edit: 8 months 3 weeks ago by PPRI.

Please Log in to join the conversation.

More
8 months 3 weeks ago - 8 months 2 weeks ago #188740 by cdorin
Hello Young, let's continue the conversation on the bugs tracker :) (thanks for create a bug report!). I pinged Markus in there.

Link: bugs.limesurvey.org/view.php?id=15265
Last edit: 8 months 2 weeks ago by cdorin. Reason: bhaaa, thanks Deni for the heads up!

Please Log in to join the conversation.

More
3 weeks 6 days ago #198909 by kjnerhus
Hi, I have premium, but I can not find the plugin in the Limestore anymore, are you working on an update for LS 4.2?

Please Log in to join the conversation.

More
3 weeks 6 days ago #198926 by cesystra
Hello,
I have the same issue here, LS 4.2.2+200504 and premium subscription but I cannot install the plugin nor find it on the LimeStore.
Thanks.

Please Log in to join the conversation.

More
3 weeks 1 day ago #199229 by cdorin
Thank you for the heads up - we are working on that and apologise for the created inconveniences.
The following user(s) said Thank You: cesystra

Please Log in to join the conversation.

More
2 weeks 2 days ago #199638 by ollehar
The 2FA plugin is now available again in the LimeStore. I will check next to make it compatible for LimeSurvey 4 too. Please wait.

Please Log in to join the conversation.

More
2 weeks 2 days ago #199661 by ollehar

cesystra wrote: Hello,
I have the same issue here, LS 4.2.2+200504 and premium subscription but I cannot install the plugin nor find it on the LimeStore.
Thanks.


Please to go this page and download the plugin: www.limesurvey.org/limestore/extensionde...administration-login

It should work for LimeSurvey 4. Let us know if you have any further issues.

Please Log in to join the conversation.

More
2 weeks 1 day ago #199744 by kjnerhus
Hi, i have Limesurvey 4.2.4 and installed the new plugin 1.2.2. Installation worked and I activated the plugin.

Nothing happens when I press the button "register 2FA now".
Have tried Firefox, Opera, Safari and Chrome on Mac. The same thing happens in all browsers.
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
2 weeks 14 hours ago #199795 by ollehar
@kjnerhus Thanks for testing. Can you click F12 in the browser (Firefox or Chrome) to enable debug window? Then click the "Console" window and give us a screenshot of any error message (presented in red text). Thank you.

Please Log in to join the conversation.

More
2 weeks 13 hours ago #199799 by kjnerhus
This is what I got:

TypeError: window.TFAUser is undefineduserindex:552:1
<anonymous> martinasurvey.no/_kne/index.php/admin/pl...method/userindex:552
jQuery 7
dispatch
handle
trigger
triggerHandler
<anonymous>
e
t

Please Log in to join the conversation.

More
2 weeks 12 hours ago #199802 by ollehar
OK, it shows that a script is not initialized as it should. Where is your upload/ folder located? Are all your folders in a standard web root?

Please Log in to join the conversation.

More
2 weeks 10 hours ago #199816 by kjnerhus
Yes it is in a standard web root. Could it be a thing with permissions?

Please Log in to join the conversation.

More
2 weeks 10 hours ago #199818 by ollehar

kjnerhus wrote: Yes it is in a standard web root. Could it be a thing with permissions?


It shouldn't be a problem with permission. If you're using a standard Linux setup, everything is readable for all users, which should be enough to load the script file for the web user. Hm hm.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now