Solved the issue of plugin reinstallation

More
1 month 1 week ago - 1 month 1 week ago #200063 by JSinitson
I solved an issue and hope it will help others running in it.

I could not reinstall a plugin. Although I deactivated and deleted it using the plugin manager I still saw the old version (the one without settings). Deleting through the file browser in the plugin manager was not possible for some reason.

So here is my solution which worked (assumed the plugins name is myplugin):

Search for that plugin in the filesystem:
$ cd limesurvey
$ find . -iname "*myplugin*"

Ensure all the files listed are related to the plugin above. Most probably this will be the case, so just loop and delete them like this:
$  for i in $(find . -iname "*myplugin*"); do echo 'removing ' $i; rm -fr $i; done

Reinstall the plugin and voila you have the current version of it.
Last edit: 1 month 1 week ago by JSinitson.

Please Log in to join the conversation.

LimeSurvey Partners

Start now!

Just create your account and start using Limesurvey today.

Register now