DatePicker is not displayed

More
1 year 3 weeks ago - 1 year 3 weeks ago #185741 by FriedrichSimon
Hello Community
I have the following problem: With the question type "Date/Time" the icon for the DatePicker is displayed in OfflineSurveys, but no box for selecting the date opens. Selecting the displayed text box only opens the normal on-screen keyboard. See screenshot.

The problem only seems to affect a few Date/Time fields - I haven't been able to find any systematics yet. Does anyone have a similar problem? Or better yet, a solution?

I have already tried to recreate the field - unfortunately without success.

I work with version Limesurvey 3.12.3+180627 - and version 1.53 of OfflineSurveys.

Thank you for your time


Update: It looks like the first DateTime field doesn't work. I'll try to create a sample survey and make it available here soon.



Attachments:
Last edit: 1 year 3 weeks ago by FriedrichSimon.
The topic has been locked.
LimeSurvey Partners
More
1 year 3 weeks ago #185747 by FriedrichSimon
I've added a *.lss with 3xDateTime fields. As you can see on the screenshot: DatePicker No.2 does not work but DatePicker No.1 does.

Has been tested on a Galaxy Tab A(2016) model: SM-T580.


Attachments:
The topic has been locked.
More
1 year 3 weeks ago #185836 by aaskoura
Hi,
TLDR; please refresh your survey on offlineSurveys... it should be working now.. would be great if you can confirm so...

OfflineSurveys attempt at 1.capturing date time input (like date format and min/max date) and 2.disabling LimeSurveys dateTime picker in favour of the device native picker... there are some changes in dateTime questions on latest LimeSurvey releases that made capturing input fail... From now on, LimeSurvey dateTime picker will not be disabled unless date inputs are captured properly
The following user(s) said Thank You: FriedrichSimon
The topic has been locked.
More
1 year 3 weeks ago #185847 by FriedrichSimon
It's working! Good work. Many thanks for the quick fix.
The topic has been locked.
More
1 year 2 weeks ago #185922 by aaskoura
Hi, can you refresh your survey once more... the native dateTime picket should be working now... would be great if you can confirm that it is working for you
The topic has been locked.
More
1 year 1 week ago #186217 by FriedrichSimon
still working :)
The topic has been locked.

Start now!

Just create your account and start using Limesurvey today.

Register now