about email setting

More
7 years 10 months ago #105296 by limedong
about email setting was created by limedong
I want to use the email function, for example, if someone wants to save the test and restart it after some time, can limesurvey send an email to the user?

I have try some times, limesurvey can save the test, but it didn't send email to me.

How to set the email setting? I haven't install mail server in my server.
The topic has been locked.
More
7 years 10 months ago #105299 by DenisChenu
Replied by DenisChenu on topic about email setting
Hi,

Without mail server in your server: you need to configure a smtp server.
Look at "Global settings"/Mail

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
7 years 10 months ago #105300 by limedong
Replied by limedong on topic about email setting

Hi,

Without mail server in your server: you need to configure a smtp server.
Look at "Global settings"/Mail


Thanks, but how to configure the smtp server if i use gmail.
The topic has been locked.
More
7 years 10 months ago #105302 by DenisChenu
Replied by DenisChenu on topic about email setting
Hi,

manual.limesurvey.org/Optional_settings#Email_Settings

Then you just have to add the port : smtp.gmail.com:465
And i think gmail use SSL or startSSL

You can test the eamil process with creating a survey with token and try to send you an email (even with a empty survey).

If your configuration are OK, you receive the mail.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
7 years 10 months ago - 7 years 10 months ago #105329 by limedong
Replied by limedong on topic about email setting
Thank you for your reply.

I try it several times, but it can not work now.

please see the attachments. But I have deleted the correct username of gmail on the pictures.
Attachments:
Last edit: 7 years 10 months ago by limedong.
The topic has been locked.
More
7 years 10 months ago #105333 by DenisChenu
Replied by DenisChenu on topic about email setting
Hi,

Can you set debug > 1 in application/config/config.php too please ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
7 years 10 months ago #105366 by limedong
Replied by limedong on topic about email setting

Hi,

Can you set debug > 1 in application/config/config.php too please ?

Denis

Thanks, I have edited the file, but it doesn't work yet.
The topic has been locked.
More
7 years 10 months ago #105377 by limedong
Replied by limedong on topic about email setting
I used another email server. It works now.Thanks for your help.
The topic has been locked.
More
7 years 10 months ago #105392 by Mazi
Replied by Mazi on topic about email setting

I used another email server. It works now.Thanks for your help.

You're welcome :-)

If our hints have been helpful and you enjoy limesurvey please consider a donation to give LimeSurvey a future .

We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com
Want to use your survey offline -> www.offlinesurveys.com
The topic has been locked.
More
7 years 1 month ago #114958 by email
Replied by email on topic about email setting
I have the same problem as Limedong.

I uses the correct settings of my smtp-server but Limesurvey is not able to send an email by smtp if a person wants to participate at my survey.

To send the email by php is not secure, right?


What else can I do to solve my problem? Seems to be a bug but hard to reproduce because I have no idea why some smtp-servers are working and some not.
The topic has been locked.
More
7 years 1 month ago #114959 by holch
Replied by holch on topic about email setting
This is very hard to say, because of course it could be a Limesurvey bug, but it could also easily be a badly configured SMTP server. Some SMTP server for example block the sending of emails from webapplications, which might also be a problem.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.
The topic has been locked.
More
7 years 1 month ago #114960 by holch
Replied by holch on topic about email setting
If you can get into touch with the administrator of the SMTP server, you might be able to check if something shows up in the logs and if you can identify what happens when Limesurvey tries to connect to the SMTP-Server to send emails.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.
The topic has been locked.

Start now!

Just create your account and start using Limesurvey today.

Register now