Welcome to the LimeSurvey Community Forum

Ask the community, share ideas, and connect with other LimeSurvey users!

Survey settings menu completely missing in 6.4 / 6.5 after fresh install

  • neismark
  • neismark's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
1 month 3 weeks ago - 1 month 3 weeks ago #259888 by neismark
Please help us help you and fill where relevant:
Your LimeSurvey version:   6.5.2+240402
Own server or LimeSurvey hosting: Own server (Ubuntu 22.04.3 LTS (Jammy Jellyfish), Apache-2.4.52)
Survey theme/template: Fruity TwentyThree
==================

There is no survey settings menu. It just does not appear. If I click on the "Structure" button, I can view my question group / question structure. But clicking on the "settings" tab (in German: "Einstellungen") just shows empty space on the left where the settings menu should appear. There is no arrow icon or any other thing I could use to change that.

A fresh install of lime survey  limesurvey6.4.4+240130.zip on a brand new Linux system didn't work and today's update to limesurvey6.5.2+240402.zip didn't work either.

What is wrong here?
Should I switch back to Lime Survey 5.x? 

Regards, 
Mark
Last edit: 1 month 3 weeks ago by neismark. Reason: Minor corrections in text

Please Log in to join the conversation.

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
1 month 3 weeks ago #259894 by DenisChenu
Did you create your own menu on 5 ?

Else : maybe you need to reset menu and menu items ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
I don't answer to private message.

Please Log in to join the conversation.

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
1 month 3 weeks ago #259909 by holch
Sometimes the browser cache is also playing games. Try to use a different browser and / or different device and see what happens.

A fresh install of lime survey limesurvey6.4.4+240130.zip on a brand new Linux system didn't work


What does that actually mean? There are different levels of "did not work". Any error messages? What did not work?

Because if your Linux system is configured right (and has the required versions of PHP, SQL, etc.) there shouldn't be any issues.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
1 month 3 weeks ago #259910 by holch
And another information that might be relevant here:

Did you update via Comfort Update or manually?

If manually: make sure you uploaded all files. Especially with FTP it is not uncommon that not all files make it to the server. Wouldn't be the first time.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

  • neismark
  • neismark's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
1 month 3 weeks ago #259911 by neismark
No, I didn't create any own menus. I had expected to work it like it was known to me from prior versions (4 and 5)

Please Log in to join the conversation.

  • neismark
  • neismark's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
1 month 3 weeks ago #259912 by neismark

 What does that actually mean? There are different levels of "did not work". Any error messages? What did not work?
Because if your Linux system is configured right (and has the required versions of PHP, SQL, etc.) there shouldn't be any issues.Well, there is no

Ok, let me elaborate a bit more...

"Does not work" means that the survey settings menu does not appear. There are absolutely no hints, error messages or anything else.
The OS was newly installed. The linux distro used is a fairly standard Ubuntu server install that we must have deployed in the hundreds in our data center.

I first installed a 6.4.4+240130 a few weeks earlier and noticed the menu was missing. This week I tried to something about that. But I didn't update. Instead I installed the most  current 6.5 version in a parallel directory in my DocRoot, copying all the relevant files, but keeping the original database. So I now have a current codebase, but the menu is still missing.

Because if your Linux system is configured right (and has the required versions of PHP, SQL, etc.) there shouldn't be any issues.

That's what you should think, shouldn't you?
At least I am not aware of any PHP modules I might have left out.

Regards
Mark

Please Log in to join the conversation.

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
1 month 3 weeks ago #259913 by holch
Well, it works for others. E.g. for me. Also, otherwise we would see a lot of complaints here in the forum.

The menu is still there. The GUI looks slightly different, but overall, the functionality hasn't changed.

With the information we have from your side, I can only guess a couple of issues:
- your LAMP enviroment does not match the requirements for LS 6.x (I assume you checked this already, but if not: manual.limesurvey.org/Installation_-_Lim...rvey_on_your_website )
- The browser cache or the asset cache is playing tricks on you (shouldn't be the case, becasue you have the same issue in two different versions in two different installations).
- Some kind of script / add blocker browser addon is blocking things (therefore also my suggestion to check with a different / clean browser)
- something went wrong with the upload and not all files have been transmitted.

Those are my points based on the info we got.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
1 month 3 weeks ago #259914 by holch
Though, my first installation has been made with an older version of LS 6 and I just updated it via Comfort Update.

So in theory there is also the chance that there is a bug in LS 6.4.4+240130 and following (e.g. files missing in the Zip file), but during the CU these issues don't appear, because there are still the old files.

However, I am sure if this would be a general issue with LS6 we would see a lot of similar complaints here in the forum, which just hasn't happened. And this would be at least for 1 month already. So chances that you are the only one that installed LS 6 completely new since 30/01/2024 are pretty slim.

So my current focus would be on your installation specifically, rather than a general bug.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
1 month 3 weeks ago - 1 month 3 weeks ago #259915 by holch
That is how it looks like on LS 6.4.11+240304 aus. After an update to LS 6.5.2+240402 it still looks the same.

 

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Last edit: 1 month 3 weeks ago by holch.

Please Log in to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #260162 by wolf
Hello,

I have a similar problem on the official limesurvey hosting after updating from v5 around 2 weeks ago: I can see the survey settings, but no survey menu (with the responses and participants menu and others).
I used different browsers and deleted the asset cache.
Any hints?

Thanks,

Wolf
Last edit: 1 month 2 weeks ago by wolf.

Please Log in to join the conversation.

More
1 month 2 weeks ago #260164 by wolf
Found the solution: resetting survey menu AND survey menu entries in settings resolved the problem (thanks to DenisChenu, see post below).

Please Log in to join the conversation.

Lime-years ahead

Online-surveys for every purse and purpose