Not Redirect URL after Survey

More
2 weeks 4 days ago #239668 by juliodiz
Please help us help you and fill where relevant:
Your LimeSurvey version: 5.6.0 (confort update)
Own server or LimeSurvey hosting: My Server
Survey theme/template: Back
==================
Hello.

Using template from survey-consulting.com Backy the URL Redirect don't work , I contact survey-consulting.com but says its a LimeSurvey problem.

How can I debug the template and check the Redirect URL?
 

Please Log in to join the conversation.

More
2 weeks 4 days ago #239677 by tpartner
Does the redirect work when testing with a core survey theme?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
2 weeks 4 days ago #239678 by juliodiz
Yes, but survey-consulting told was a limesurvey problem.

Please Log in to join the conversation.

More
2 weeks 4 days ago #239682 by tpartner
Well, if it works with a core theme, it certainly looks like a problem with the template (although I don't see how a template could affect the redirect).

Explain more about how you implement the redirect. Are there conditions, etc?

Explain

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
2 weeks 4 days ago #239684 by jelo
Replied by jelo on topic Not Redirect URL after Survey

How can I debug the template and check the Redirect URL?
 
Create a new survey and enter a common URL (e.g google.com) and activate the Redirect-Option.
Is that working with a coretheme? Is that working with the theme from survey-consulting.
Since you are on LS 5.6 you should test it with a fresh survey on both themes.
 

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in to join the conversation.

More
2 weeks 4 days ago #239685 by juliodiz
I always use redirect (google for example) but im change to backy but the survey goes back to first question and not redirect.

I change to vanilla and redirect works, its possible to debug the backy theme the step of redirect and why is going back to start survey?

Please Log in to join the conversation.

More
2 weeks 4 days ago #239686 by jelo
Replied by jelo on topic Not Redirect URL after Survey

I always use redirect (google for example) but im change to backy but the survey goes back to first question and not redirect.
 
Did backy every worked for you? When did you update to LS 5.6?
 

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in to join the conversation.

More
2 weeks 4 days ago #239687 by juliodiz
I just bought backy from survey-consulting

Please Log in to join the conversation.

More
2 weeks 4 days ago #239692 by Mazi
Replied by Mazi on topic Not Redirect URL after Survey
Julio, as outlined previously, please send me the survey details (URL, login) by email (This email address is being protected from spambots. You need JavaScript enabled to view it.) and we will investigate.

I have no idea how the default redirect can cause issues when using different templates but as promised, I can look into it if you provide access to your survey.

Best regards/Beste Grüße,
Dr. Marcel Minke
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com
Want to use your survey offline -> www.offlinesurveys.com

Please Log in to join the conversation.

More
2 weeks 2 days ago #239715 by juliodiz
Done.

Please Log in to join the conversation.

More
1 week 5 days ago - 1 week 5 days ago #239796 by juliodiz
Checking the files from backy, missing some view files.

WrongTemplateVersionException
Missing layout layout_user_forms.twig

 
Attachments:
Last edit: 1 week 5 days ago by juliodiz.

Please Log in to join the conversation.

More
1 week 5 days ago - 1 week 5 days ago #239799 by Mazi
Replied by Mazi on topic Not Redirect URL after Survey

Checking the files from backy, missing some view files.

WrongTemplateVersionException
Missing layout layout_user_forms.twig
This is not a problem with the Backy template from survey-consulting.com/product/limesurvey-template-backy/. Missing files are always inherited from a core theme. We tested this with your theme and it works fine at our system.
As you have confirmed, your survey also runs correctly with your template on our systems. So the redirect issue also is not template related. Therefore, we can close this topic.

Best regards/Beste Grüße,
Dr. Marcel Minke
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com
Want to use your survey offline -> www.offlinesurveys.com
Last edit: 1 week 5 days ago by Mazi.

Please Log in to join the conversation.

More
1 week 5 days ago - 1 week 5 days ago #239800 by juliodiz
The problem was fixed using extended vanilla.

Thanks to Marcel Minke for support.
Last edit: 1 week 5 days ago by juliodiz.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now