Weird server behaviour regarding the DNS

More
2 weeks 3 days ago #228240 by lechesnayrocquencourt
Please help us help you and fill where relevant:
Your LimeSurvey version: Version 5.3.12+220502
Own server or LimeSurvey hosting: Self Hosted (behind a reverse proxy firewall
Survey theme/template: Fruity
==================
Hello Gals and Guys,

I have successfully installed a new Limesurvey server on a Debian 11 / Apache 2.5.25 / MariaDB 10.5.15.
The installer run successfully and no error have been generated.

The server is providing a http service that is secured by a reverse proxy running on our firewall.

The server works in https on the DNS entry ( enquetes.lechesnay-rocquencourt.fr/ ) and in http on the internal IP address on our lan.

Unfortunately, the DNS address keeps being redirected to the IP address of the server when I try to access the administration page.
The IP being in our DMZ, it can’t be accessed from the wan and the participants cannot access the survey.
The links in the emails sent to the participants are also referring the IP address.

It seems that the server rewrites every requests to be served on the IP address rather than on the DNS entry despite the fact that looks correct in the Apache conf file:
<VirtualHost *:80>
     ServerAdmin xxxxxxx@xxxxx.fr
     DocumentRoot /var/www/html/limesurvey
     ServerName enquetes.lechesnay-rocquencourt.fr
 
     <Directory /var/www/html/limesurvey>
          Options FollowSymlinks
          AllowOverride All
          Require all granted
     </Directory>
 
     ErrorLog ${APACHE_LOG_DIR}/enquetes.lechesnay-rocquencourt.fr_error.log
     CustomLog ${APACHE_LOG_DIR}/enquetes.lechesnay-rocquencourt.fr_access.log combined
 
</VirtualHost>

Is there any setting in Limesurvey that I can use to make it aware of the DNS record?

Thanks you for your assistance :)

PAH

Please Log in to join the conversation.

More
2 weeks 2 days ago #228314 by lechesnayrocquencourt
I have fixed the problem.
For info, you should add the serveur url in the config file located here: application/config/config.php.

The serveur public url can be declared using the publicurl directive in the following section:
'config'=>array(
'debug'=>0,
'debugsql'=>0, // Set this to 1 to enanble sql logging, only active when debug = 2
[u][b]'publicurl'=>'https://enquetes.lechesnay-rocquencourt.fr',[/b][/u]
// Mysql database engine (INNODB|MYISAM):
'mysqlEngine' => 'MYISAM'
 
, // Update default LimeSurvey config here
)

It’s frustrating that the doc is not more explicit on this topic:
manual.limesurvey.org/Optional_settings

For others that might be looking for a solution using the search engine, here are a few keywords:
  • Limesurvey DNS;
  • Limesurvey server URL;
  • Limesurvey webapp path;
  • Limesurvey FQDN.

Please Log in to join the conversation.

More
2 weeks 2 days ago #228321 by tpartner
The documentation is a wiki so you can add or edit it.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now