composer eror: facebook/webdriver "ext-zip" missing

More
1 month 3 weeks ago - 1 month 3 weeks ago #220910 by limesurvey_asker
My enivronment is: Limesurvey Version on LTS 3.27, PHP 7.4, Linux, MySQL 8.0 . Trying to run composer, I get this:
- facebook/webdriver[1.4.0, ..., 1.7.1] require ext-zip * -> it is missing from your system. Install or enable PHP's zip extension. - Root composer.json requires facebook/webdriver ^1.4 -> satisfiable by facebook/webdriver[1.4.0, ..., 1.7.1]

Googling tells me "This package is abandoned and no longer maintained. The author suggests using the php-webdriver/webdriver package instead. " (link ) - so Should I change the name of the package? Another Googling tells me "add ext-zip to your required section of composer.json"
([url=https://stackoverflow.com/questions/56219962/composer-require-ext-zip-fails]link[/url]){ "require" : { "ext-zip": "*" } }
Do you have tipps what I should do to resolve this issue? Not 100% sure which is the right approach here.
Last edit: 1 month 3 weeks ago by limesurvey_asker.

Please Log in to join the conversation.

More
1 month 3 weeks ago #220917 by DenisChenu
Why you try to run composer ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.

Please Log in to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #220966 by limesurvey_asker
Well I am running my limsurvey on a virtual docker-like environment. The source code sits inside an image. When I update the source code, composer will be run automatically (to make sure the right packages are installed to run the application). If I did not run composer (deleting composer.json) and something required misses, I will run into the same problem, or not?
Last edit: 1 month 2 weeks ago by limesurvey_asker.

Please Log in to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #220971 by DenisChenu
It's requrire-dev : --no-dev can do the trick.

I think best solution is

1. report the issue
2. Fix your docker continuous integration to use --no-dev
3. if don'(t work : delete composer.json for your project

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
Last edit: 1 month 2 weeks ago by DenisChenu.

Please Log in to join the conversation.

More
1 month 2 weeks ago #220984 by limesurvey_asker
ok so as long as I don't do development, I can just make facebook/webdriver that a non-requirement?
php composer.phar require php-webdriver/webdriver manually works by the way.
php composer.phar require facebook/webdriver works also manually.

Please Log in to join the conversation.

More
1 month 2 weeks ago #220986 by DenisChenu
getcomposer.org/doc/03-cli.md#install-i

php composer.phar --no-dev

If you don't create a dev webserver : ALWAYS add --no-dev …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.

Please Log in to join the conversation.

More
1 month 2 weeks ago #221041 by limesurvey_asker
ok thx! My system runs composer automatically, so I just deleted this require-dev part ...

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now