LDAP module bugs

More
9 months 4 weeks ago #219205 by jelen1
LDAP module bugs was created by jelen1
After upgrading (ComfortUpdate) to version 5.1.4+210824  from last version 3.xx,  LDAP autentication stoped working.
Bugs are in the file AuthLDAP.php.
1. strpos() function has wrong syntax "str_pos()".
2. some other minor changes disallow (after correction strpos error) finding users.
Sollution: I replaced the module with the previous version AuthLDAP.php and it work well again.
It would probably be a good idea to check this module before it becomes part of the next update
 
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
9 months 4 weeks ago #219221 by tpartner
Replied by tpartner on topic LDAP module bugs
Please file a bug report.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The following user(s) said Thank You: jelen1

Please Log in to join the conversation.

More
9 months 4 weeks ago #219223 by jelen1
Replied by jelen1 on topic LDAP module bugs
Thank you. I couldn't find the right page. "bug report" was right phrase. I already found it and reported bug.
The following user(s) said Thank You: tpartner

Please Log in to join the conversation.

More
9 months 4 weeks ago #219228 by tpartner
Replied by tpartner on topic LDAP module bugs

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now