Error when updating database

More
10 months 2 weeks ago #218815 by elissa
Hello,
I run Comfort Update from LS 5.0.8 to LS 5.0.13. When it came to upgrading a database I've got this error (I translated it into English):

An unrecoverable error occurred while updating.
Error description:Invalid signature
File Compat.php, row 2650.
Please correct the error in the database and try again


PHP on my server is 7.3.
I've found the compat.php file in "third_party/paragonie/sodium_compat/src"
and the 2649 and 2650 rows are:
        if (PHP_INT_SIZE === 4) {
            return ParagonIE_Sodium_Crypto32::sign_open($signedMessage, $publicKey);

but I do not know what to do (I don't know anything about coding). Can you suggest how to solve it?
Thank you.
 

Elzbieta Lesinska
LS voluntary Polish translator and supervisor
Attachments:

Please Log in to join the conversation.

More
10 months 1 week ago #218871 by ollehar
Version 5.1.1 is released, please try again with this new version and let us know if any problems remain. Thank you!

Please Log in to join the conversation.

More
10 months 1 week ago #218875 by ollehar
5.1.2 released.

Please Log in to join the conversation.

More
10 months 1 week ago #218896 by elissa
Replied by elissa on topic Error when updating database
Thank you for your response. As I don't have access to ComfortUpdate anymore (due to the error), I updated to 5.1.2 manually. Unfortunatelly, I'm stuck in the same place.

Elzbieta Lesinska
LS voluntary Polish translator and supervisor

Please Log in to join the conversation.

More
10 months 1 week ago #218910 by elissa
Replied by elissa on topic Error when updating database
I went back to version 5.0.8 from the backup and restored the backuped database. Then I run the Comfort Update to 5.1.3 and I'm still in the same place with the same error when upgrading the database.

Elzbieta Lesinska
LS voluntary Polish translator and supervisor

Please Log in to join the conversation.

More
10 months 1 week ago #218979 by elissa
Replied by elissa on topic Error when updating database
I'm not very happy with the solution but finally I created a completely new installation of LS5 (I'm lucky that all may production surveys are still in another LS3 installation).

Elzbieta Lesinska
LS voluntary Polish translator and supervisor

Please Log in to join the conversation.

More
10 months 1 week ago #218980 by ollehar
Sorry, I missed this forum thread. If you have ComfortUpdate you can use our support system instead to make sure you're not missed.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now