Deactived Force HTTPS - can't access Limesurvey

More
2 months 1 week ago #204114 by ch123
Hey.
I got a problem. I wanted to try my general (security) settings because I currently have problems with displaying my surveys in another application via IFrame. Unfortunately, I changed it a bit too fast without thinking about it.
In the Global Settings I have turned off "Force HTTPS" - before I had it activated. Now I cannot access my LimeSurvey instance anymore.
Is there a way to change this? Or do I have to reinstall LimeSurvey?
The manual says: "If you activate HTTPS by mistake, you can deactivate it in application/config/config.php file, changing the value of ssl_emergency_override to 1", but I don't quite understand that... Is it possible the other way around as well?


Thank you!

Please Log in to join the conversation.

LimeSurvey Partners
More
2 months 1 week ago #204116 by Joffm
You may change the value in the database.

In table "lime_settings_global" set value "force_ssl" to "off"

Joffm

And next time do not ignore this


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:
The following user(s) said Thank You: ch123

Please Log in to join the conversation.

More
2 months 1 week ago #204117 by ch123
Ah thank you so much, great :D
Just set the value to "on", but it worked the other way around as well.
Saw that hint, but I thought that it wouldn't be a problem to switch it off when it worked before. But I won't ignore it next time, thanks!

Please Log in to join the conversation.

More
2 months 1 week ago #204165 by holch
What I don't understand is, why there would be a problem if you switch this off. I can understand that there can be problems when you switch this on and force Limesurvey to use https, but there is no valid SSL certificate.

But if you have a certificate and you switch this off, there should be no problem. You should be able to access via http AND https.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
2 months 1 week ago #204185 by ch123
That was my thought as well - but without any knowledge in this field... I don't know.
Maybe there's a restriction from my server or something?
But it's working now :D

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now