Translation Issues

More
2 years 2 weeks ago - 2 years 2 weeks ago #200997 by Iskandar_r
Sorry if I wrote in the wrong category, I did not find a suitable one.

After switching to version 4, there were problems with the translation. Some user interface items are not translated
although these items have been translated in the translation file. (see screenshots)
Does anyone know how to solve this?
limesurvey4.2.7+200604
Attachments:
Last edit: 2 years 2 weeks ago by Iskandar_r.
The topic has been locked.
More
2 years 2 weeks ago #201001 by holch
Replied by holch on topic Translation Issues
There was a discussion about this a couple of weeks ago. It seems like there is a bug that prevents certain strings to be recognized by Limesurvey, even if they are translated in the translation files.

All in all, I currently can not recommend LS 4.x for production use yet. Stay with 3.x for now, would be my suggestion.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.
The topic has been locked.
More
2 years 2 weeks ago #201008 by holch
Replied by holch on topic Translation Issues
It might be related to this bug:
bugs.limesurvey.org/view.php?id=16337

If so, please comment on the bug, which might help to raise awareness among core developers and create pressure to fix it asap.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.
The following user(s) said Thank You: Iskandar_r
The topic has been locked.
More
2 years 1 week ago #201017 by Iskandar_r
Replied by Iskandar_r on topic Translation Issues
Yes that's it.
Thanks, I will comment.
The following user(s) said Thank You: tpartner
The topic has been locked.
More
2 years 1 week ago - 2 years 1 week ago #201088 by Iskandar_r
Replied by Iskandar_r on topic Translation Issues
There is no solution to this problem yet, I decided to try changing the text in the source code to another language.
For example, the word " Create Question group " is located in the \assets\packages\questiongroup\build\js\questiongroupedit.js file
but changing the text in this file does not take effect..
Is there another way to change the text as a temporary solution to this problem?
Last edit: 2 years 1 week ago by Iskandar_r.
The topic has been locked.
More
2 years 1 week ago #201096 by holch
Replied by holch on topic Translation Issues
Not that I know of or that I could think of.

I would recommend to go back to 3.x anyway. 4.x has other problems as well at the moment.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.
The topic has been locked.
More
2 years 1 week ago #201142 by Iskandar_r
Replied by Iskandar_r on topic Translation Issues

holch wrote: Not that I know of or that I could think of.

I would recommend to go back to 3.x anyway. 4.x has other problems as well at the moment.

OK!
Thanks.
The topic has been locked.

Start now!

Just create your account and start using Limesurvey today.

Register now