Hi everyone,
I've got a Limesurvey installation running that I've set up roughly 3 years ago but didn't use it much in the recent past. Yesterday I disregarded the old proverb "Never change a running system!" and updated the webserver's Ubuntu distro (16.04 -> 18.04). It all went well and the webserver is back up and running (i.e. I can access websites stored in /var/www/html/).
The problem is that my Limesurvey installation is now inaccessible but I cannot figure out the reasons for it. That's why I would like to ask the community if maybe someone could help me with my problem. I've already tried to reinstall Limesurvey but to no avail.
When I try to access it via "domain.name/limesurvey/" or "domain.name/limesurvey/admin", I get the following message in the form of a html page:
Code:
0) { define('YII_DEBUG', true); if($aSettings['config']['debug']>1) error_reporting(E_ALL); else error_reporting(E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED); } else { define('YII_DEBUG', false); error_reporting(0); } } else { error_reporting(E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED);// Not needed if user don't remove his 'debug'=>0, for application/config/config.php (Installation is OK with E_ALL) } if (version_compare(PHP_VERSION, '5.3.3', '<')) die ('This script can only be run on PHP version 5.3.3 or later! Your version: '.PHP_VERSION.'
'); /** * Load Psr4 autoloader, should be replaced by composer autoloader at some point. */ require_once 'application/Psr4AutoloaderClass.php'; $loader = new Psr4AutoloaderClass(); $loader->register(); $loader->addNamespace('ls\\pluginmanager', __DIR__ . '/application/libraries/PluginManager'); $loader->addNamespace('ls\\pluginmanager', __DIR__ . '/application/libraries/PluginManager/Storage'); $loader->addNamespace('ls\\menu', __DIR__ . '/application/libraries/MenuObjects'); $loader->addNamespace('ls\\helpers', __DIR__ . '/application/helpers'); /* * -------------------------------------------------------------------- * LOAD THE BOOTSTRAP FILE * -------------------------------------------------------------------- * * And away we go... * */ require_once BASEPATH . 'yii' . EXT; require_once APPPATH . 'core/LSYii_Application' . EXT; $config = require_once(APPPATH . 'config/internal' . EXT); if (!file_exists(APPPATH . 'config/config' . EXT)) { // If Yii can not start due to unwritable runtimePath, present an error $sDefaultRuntimePath = dirname(__FILE__).DIRECTORY_SEPARATOR.'tmp'.DIRECTORY_SEPARATOR.'runtime'; if (!is_dir($sDefaultRuntimePath) || !is_writable($sDefaultRuntimePath)) { // @@TODO: present html page styled like the installer die (sprintf('%s should be writable by the webserver (766 or 776).', $sDefaultRuntimePath)); } } Yii::$enableIncludePath = false; Yii::createApplication('LSYii_Application', $config)->run(); /* End of file index.php */ /* Location: ./index.php */
Can't make much out of this error message. Only thing I could find is a referral to PHP not having a high enough version. So I've checked in /etc/php/ and found that there are two installed versions, namely 7.0 and 7.2, each in its own folder.
So I was wondering if PHP is even found and working at all. I've created a phpinfo file under /var/www/html/ and accessed it via browser. The page stays empty.
Now I know that this is my own fault and everything (shouldn't have upgraded in the first place, I guess) but I have high hopes that some of you might know what the problem could be. So if someone could point me in the right direction, I'd be very grateful.
Thank you in advance!
Best wishes