Logging SMTP problems

More
1 year 1 month ago #185730 by jr00n
Logging SMTP problems was created by jr00n
Hi, i've got LS working on OpenShift. Done with the s2i php builder from OpenShift.
App works, but i can't get mail getting to work. Probably something simple, but i can't find any logs.
I have enabled SMTP debug mode: always in the configuration page.

Where can i find that log file?

Thanks,

Jeroen

Please Log in to join the conversation.

LimeSurvey Partners
More
1 year 1 month ago #185744 by DenisChenu
Replied by DenisChenu on topic Logging SMTP problems
Complete log is shown when you send a token email only.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.

Please Log in to join the conversation.

More
1 year 1 month ago #185812 by jr00n
Replied by jr00n on topic Logging SMTP problems
Hi Denis, i don't understand.
What do you mean by a token email only?
I want to find the application (debug) log somewhere.
When i test it with lost password procedure (index.php/admin/authentication/sa/forgotpassword)
the only message i get is that mail sending was failed. Can't figure out why.
I'm running it in a container on kubernetes and would like to see the application logging to console

Please Log in to join the conversation.

More
1 year 1 month ago - 1 year 1 month ago #185815 by DenisChenu
Replied by DenisChenu on topic Logging SMTP problems

Debug part are shown when sending email to participant .

From the manual
manual.limesurvey.org/Global_settings#Email_settings


Then :
1. Create a survey (don't need any question)
2. Create a token table
3. Add your email as participant
4. Send email
5. See the debug of SMTP

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
Attachments:
Last edit: 1 year 1 month ago by DenisChenu.

Please Log in to join the conversation.

More
11 months 2 weeks ago #188027 by lightweight
Replied by lightweight on topic Logging SMTP problems
It'd be mighty useful to have a "test email" functionality on the SMTP configuration page. At present, I've got a site I've set up which correctly/successfully uses the SMTP details to send a "token" email to new admin users... but it fails to send an email when a user goes through the "forgot password" workflow... I'm on Version 3.17.9+190731 (running on Linux in Docker).

Please Log in to join the conversation.

More
11 months 2 weeks ago #188088 by lightweight
Replied by lightweight on topic Logging SMTP problems
Huh. Seems like the ability to verify SMTP is pretty crucial to stable operation... I'm a bit puzzled that "token"-based emails work with my install, but password recovery doesn't. Do they use two different paths? I'm not sure how it works...

Please Log in to join the conversation.

More
11 months 2 weeks ago #188093 by DenisChenu
Replied by DenisChenu on topic Logging SMTP problems

lightweight wrote: Huh. Seems like the ability to verify SMTP is pretty crucial to stable operation... I'm a bit puzzled that "token"-based emails work with my install, but password recovery doesn't. Do they use two different paths? I'm not sure how it works...

No, it use exactly the same code except if you have plugins …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.

Please Log in to join the conversation.

More
4 months 2 weeks ago #195762 by garywong-bc
Replied by garywong-bc on topic Logging SMTP problems
hmmm. it works for my LS on OpenShift setup.. my config.php (template) looks like this:
github.com/garywong-bc/nrm-survey/blob/m...g-postgresql.php#L74

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now