CDbConnection failed to open the DB connection: SQLSTATE[HY000] [2002]

More
3 years 7 months ago #150068 by DenisChenu
No, currently NO SQLite support.

Yii allow it, but need some dev to put it in LS.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
3 years 7 months ago #150070 by shru123
Older version of limesurvey stated in config.php that it supports the (mysql, pgsql, mssql, sqlite, oci)drivers are supported.

I wanted to know except MySQL which driver it supports older version of limesurvey.
The topic has been locked.
More
3 years 7 months ago #150071 by DenisChenu

shru123 wrote: Older version of limesurvey stated in config.php that it supports the (mysql, pgsql, mssql, sqlite, oci)drivers are supported.

I's totally sure sqlite was NEVER supported by LS.

manual.limesurvey.org/Installation#Make_...rvey_on_your_website

PDO database driver for MySQL (pdo_mysql or pdo_mysqli) or Postgres (pdo_pgsql) or MSSQL (pdo_sqlsrv for Windows and pdo_dblib for Linux)


Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
3 years 7 months ago #151029 by shru123
My issue have been resolved after enabling pdo_mysql in php.ini. old version of limesurvey works in Apache 2.4.25/Php ver 7.1.1.

Thanks to all...
The topic has been locked.
More
3 years 7 months ago #151030 by shru123
One more question Any chart diagrams like (pie , graph) type something like we do in PPT after poplutaing data we have various charts. So same facility we have in limesurvey
The topic has been locked.

Start now!

Just create your account and start using Limesurvey today.

Register now