Fragegruppen werden nicht immer angezeigt

More
1 month 3 weeks ago #222470 by Eva.uibk
Hallo Zusammen,

ich habe folgendes Problem (Version 3.22.4+200212)

meine Fragebogen besteht aus einem Allgemeinen Teil A den jeder ausfüllen soll, gefolgt von einem Teil B bei in dem entweder Frage 1 oder 2 erscheint und einem Teil C mit wiederum Frage 1 oder 2.

folgendes ist gewünscht: 4 Gruppen
1. Block B 1 Block C1
2. Block B 1 Block C2
3. Block B 2 Block C1
4. Block B 2 Block C2
sprich 50/50 Chance in einem der zwei Fragenblöcke/Gruppen die erste bzw. zweite Frage zu erhalten.

Im Fragegruppen Teil A habe ich folgendermaßen randomisiert:
If(is_empty(gleichung), rand(1,4),gleichung)

In den Fragen der Fragegruppen B habe ich es jeweils wie folgt definiert:
F1: gleichung==1, gleichung ==2
F2: gleichung==3, gleichung==4

Für die Fragen der Gruppe C entsprechend mit 1 und 3 bzw 2 und 4. also ganz nach Baum-Diagramm 

leider scheint dies limesurvey gar nicht zu schmecken und ich erhalte entweder:
a) keinen der Blöcke B oder C
b) einen der Blöcke B oder C
c) manchmal beide Blöcke 

die Gruppen mit 1 und 2 zu definieren führt ja lediglich zu 2 Gruppen also wie schaffe ich es hier Teil B UND Teil C ausfüllen zu müssen und jeweils random entweder die eine oder andere Frage des jeweiligen Teils zugewiesen zu bekommen?

Danke im Voraus
 

Please Log in to join the conversation.

More
1 month 3 weeks ago #222471 by Eva.uibk
Well never mind.

„or“ hat das Problem gelöst.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now