authentification CAS

More
2 months 2 days ago #198936 by nicolasgoudard
Bonjour,

Dans l'institut où je travaille j'ai installé Limesurvey 4.2. Je voudrais utiliser l'authentification CAS pour m'authentifier via le service de l'université.
Je précise que je veux me débarrasser de mon LDAP local pour passer tous les services en connexion directe au CAS, comme je l'ai fait pour des logiciels standards comme GRR qui intègrent l'authentification CAS, ou des applications locale en PHP (en utilisant PHP CAS).
Pour cela j'ai récupéré le plugin AuhCAS de l'université de Lorraine.
mais il est incompatible avec la dernière version de Limesurvey : la liste des plugins indique que le fichier de configuration n'est pas présent pour AuthCAS, et pour tant Config.xml est bien dans le dossier du plugin avec les bons droits dans toute l'arborescence. Je pense que le plugin est trop ancien.
Y a t-il une solution sans que je sois obligé de me connecter sur le CAS à travers mon LDAP local ?

Merci par avance.
Bien cordialement

Please Log in to join the conversation.

LimeSurvey Partners
More
2 months 1 day ago #198947 by DenisChenu
Replied by DenisChenu on topic authentification CAS
Heu, il n'y a pas de fichier config.xml pour AuthCas

Sinon : le plugin ne me semble pas utiliser de système si complexe. Si il passe sur la 3, il peut, peut être, passer sur la 4.

Il faut créer le fichier config.xml et tester

Un truc du genre
<?xml version="1.0" encoding="UTF-8"?>
<config>
    <metadata>
        <name>AuthCAS</name>
        <type>plugin</type>
        <creationDate>2015-03-10</creationDate>
        <lastUpdate>2020-05-11</lastUpdate>
        <author>Guillaume Colson</author>
        <authorUrl>https://github.com/goyome</authorUrl>
        <version>1.0.0</version>
        <license>GNU General Public License version 2 or later</license>
        <description><![CDATA[CAS Authentication plugin for limesurvey (based on phpCAS)]]></description>
    </metadata>
 
    <compatibility>
        <version>2.0</version>
        <version>3.0</version>
        <version>4.0</version>
    </compatibility>
 
    <updaters>
    </updaters>
</config>

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now