Redirection de domaine et page blanche

More
3 months 6 days ago #194252 by njouvenez
Bonjour à tous.
J'ai un petit souci. J'ai installé limesurvey sur un serveur mutualisé firstheberge et tout fonctionne très bien.
J'ai fait une redirection de domaine depuis ovh et je n'obtiens qu'une page blanche. La redirection fonctionne bien, car après avoir créé un fichier test.php dans le répertoire de limesurvey, celui-ci s'affiche bien.
Pour résumer : adresseserveur/limesurvey -> ok
Redirection nom de domaine seul -> page blanche
Redirection nom de domaine/admin -> page blanche
Redirection nom de domaine/test.php -> Ok

J'avoue ne pas comprendre le problème. Si quelqu'un à une idée.

Please Log in to join the conversation.

LimeSurvey Partners
More
3 months 6 days ago #194261 by Nickko
Comment as-tu fait ta redirection ?
301 ou 302 ?
Tu pourrais nous donner l'URL de redirection qu'on puisse voir ce qui pose le problème si c'est au niveau réseau.

Nickko
Head of ergonomics, UX & UI.
The following user(s) said Thank You: njouvenez

Please Log in to join the conversation.

More
3 months 6 days ago - 3 months 6 days ago #194268 by njouvenez
Bonjour,
la redirection utilisée est une redirection de domaine depuis le gestionnaire d'OVH, modification DNS pour faire pointer le sous domaine enquete.apter.pro vers un hébergement mutualisé firstheberge (301?). Ce type de redirection fonctionne parfaitement pour un site sous spip.
Hébergement : satinebm01.mutu.firstheberg.net/limesurvey/index.php
redirection enquete.apter.pro/

Lien pour tester la redirection : enquete.apter.pro/test.php , qui renvoi bien la page

Merci
Last edit: 3 months 6 days ago by njouvenez.

Please Log in to join the conversation.

More
3 months 6 days ago #194273 by Nickko
J'ai du prendre la route, je suis sur mon mobile mais on dirait pas une redirection 301 mais plutôt une redirection moisie ?

Une pour le voir, il suffit de prendre ton test, l'URL ne change pas, une redirection, ça rediruge, on devrait donc voir la bonne URL dans la barre d'adresse.

Tu peux nous expliquer comment tu as fait ta redirection ? Voir nous donner une copie d'écran.

Nickko
Head of ergonomics, UX & UI.

Please Log in to join the conversation.

More
3 months 6 days ago #194277 by njouvenez
Alors, en lien deux captures d'écran

Sous firstheberg, à partir du manager : dans domaines associés --> ajouter un domaine et remplir les informations données (Domaine : enquete.apter.pro - Chemin /www/limesurvey/ - Alias www)

Sous OVH, à partir du manager : Dans domaines -> Redirection -> Ajouter une redirection -> Donner le domaine et/ou le sous-domaine (enquete), cocher www puis choisir vers un serveur OVH ou ailleurs. effectuer une redirection DNS via une IP (A ou AAAA) ou un Domaine (CNAME).
Choisir Avec une adresse IP
Donnée l'adresse du serveur mutualisé firstheberg
Valider
Attachments:

Please Log in to join the conversation.

More
3 months 6 days ago #194278 by Nickko
Ok, c'est donc un alias que tu as fait et non une redirection.

Il faut configurer Limesurvey pour qu'il accepte les requêtes sur ton nouveau domaine.

Normalement il suffit de se connecter via la nouvelle adresse...

Je regarde ce soir si je vois autre chose depuis mon ordi.

Nickko
Head of ergonomics, UX & UI.
The following user(s) said Thank You: njouvenez

Please Log in to join the conversation.

More
3 months 6 days ago #194280 by njouvenez
Merci pour ces retours.
Pourras tu me dire comme "configurer Limesurvey pour qu'il accepte les requêtes sur ton nouveau domaine"? car justement je ne peux me connecter avec la nouvelle adresse ...
Encore merci

Please Log in to join the conversation.

More
3 months 6 days ago - 3 months 6 days ago #194284 by njouvenez
Bonjour,
En partant du principe que la redirection était fonctionnelle pour le CMS spip, j'ai récupéré le .htaccess, modifié en remplaçant les entrées spip.php en index.php et cela fonctionne. Mais c'est vraiment du bricolage et c'est bourrin. Y a t'il une solution plus propre ? Est ce un problème d'hébergeur ? Y a t'il un menu "caché" sous limesurvey pour le faire proprement ?
Last edit: 3 months 6 days ago by njouvenez.

Please Log in to join the conversation.

More
3 months 6 days ago #194286 by Nickko
C'est très étrange que tu ais dû modifier le .htaccess, chez moi, il est comme ceci :
<IfModule mod_rewrite.c>
    RewriteEngine on
 
    # if a directory or a file exists, use it directly
    RewriteCond %{REQUEST_FILENAME} !-f
    # RewriteCond %{REQUEST_FILENAME} !-d
 
    # otherwise forward it to index.php
    RewriteRule . index.php
 
    # deny access to hidden files and directories except .well-known
    RewriteCond %{REQUEST_URI} !^/\.well-known
    RewriteRule ^(.*/)?\.+ - [F]
</IfModule>
 
# deny access to hidden files and directories without mod_rewrite
RedirectMatch 403 ^/(?!\.well-known/)(.*/)?\.+
 
# General setting to properly handle LimeSurvey paths
# AcceptPathInfo on

Aucune référence au domaine.

Je t'épargne la lecture du index.php mais pas plus de mention du domain.

Tu pourrais me montrer ton fichier d'origine ? Joint les à un message.

Sinon, comment as-tu installé Limsurvey ? Via le ZIP à téléchrger sur ce site ou sur un autre site ou directement via ton hébergeur ?

Pour éviter ce genre de problème, le mieux c'est de lier ton domain à ton hébergement sans faire d'alias ou alors de faire une vrai redirection 30x

Et pour ça, le plus simple c'est de prendre l'hébergement et le nom de domaine au même endroit.

Nickko
Head of ergonomics, UX & UI.
The following user(s) said Thank You: njouvenez

Please Log in to join the conversation.

More
3 months 6 days ago - 3 months 6 days ago #194287 by njouvenez
Effectivement le fichier d'origine est bien le même.
J'ai effectué une installation depuis le zip, il y a quelques jours sans aucun problème.

En 2016, je n'avais pas eu de problème et la redirection OVH -> firstheberg avait bien fonctionné.

Je t'avoue ne pas comprendre le "faire une vrai redirection 30x". Il va donc falloir que je me renseigne et peut être modifier la méthode que j'ai utilisé.


Encore merci
Attachments:
Last edit: 3 months 6 days ago by njouvenez.

Please Log in to join the conversation.

More
3 months 6 days ago #194288 by Nickko
Une redirection, ça veux dire faire une page chez OVH, un fichier PHP.
Plus d'info ici : www.redirection-web.net/redirection-301.php

Après, le problème est peut-être ailleurs, je ne vois pas de raison pour que ça bloque.

Nickko
Head of ergonomics, UX & UI.

Please Log in to join the conversation.

More
3 months 5 days ago #194358 by DenisChenu
Sinon,

1. Il faut régler ce problème de HTTPS ou le désactiver ...
2. A mon avis : vérifie le phpconfig, mais le domaine remonté n'est sans doute pas le bon pour le cookies de session.

Tu peux forcer le cookie de session avec le bon domaine via le fichier config.php

manual.limesurvey.org/Optional_settings#Other_sessions_update (cookieParams)

manual.limesurvey.org/Optional_settings#Request_settings hostInfo et csrfCookie

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: njouvenez

Please Log in to join the conversation.

More
3 months 4 days ago #194364 by Nickko
Merci pour cet éclairage Denis.

Nickko
Head of ergonomics, UX & UI.

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now