Relevance is not currently supported for columns

More
5 months 5 days ago #231360 by KristineAvagyan
Please help us help you and fill where relevant:
Your LimeSurvey version: Version 5.3.31

Own server or LimeSurvey hosting:
Survey theme/template:
==================

Hi, I hope someone can help on this. Starting from yesterday I am not able to add relevance equation to new variants of multiple choice questions. It says "Relevance is not currently supported for columns" 

The options till 4 were added before and the equations work fine. The 5th option was newly added. Anybody got the same issue and knows how to fix this? 

Thanks beforehand
Attachments:

Please Log in to join the conversation.

More
5 months 5 days ago #231364 by tpartner
As far as I know, relevance for the x-scale sub-questions has never worked.

In 4.x, due to a bug, you could put in an equation but it didn't actually do anything.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
5 months 5 days ago #231370 by Joffm
Hi,
I could reproduce your issue.
When you add a new subquestion the relevance equation field is grayed and throws this message.
You have to "save and close" first. Afterwards you are able to enter the relevance equation.

 
  
 
  
In my opinion a stupid new behaviour. 

Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:
The following user(s) said Thank You: KristineAvagyan

Please Log in to join the conversation.

More
5 months 5 days ago #231376 by KristineAvagyan
Hi Joffm,

Thanks a lot this worked for me.

Yes, it was totally fine 2 days ago, hope they will fix this.

Regards,
Kristine

Please Log in to join the conversation.

More
5 months 5 days ago #231377 by holch

Yes, it was totally fine 2 days ago, hope they will fix this.


Only if you make a bug report. A bug not reported is a bug not fixed.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
5 months 4 days ago #231385 by jelo

When you add a new subquestion the relevance equation field is grayed and throws this message.
You have to "save and close" first. Afterwards you are able to enter the relevance equation.
 
Is the relevance really working on both axes? I thought the GUI was updated and all fields without any function where removed.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in to join the conversation.

More
5 months 4 days ago - 5 months 4 days ago #231386 by Joffm

Is the relevance really working on both axes?
I thought the GUI was updated and all fields without any function where removed.

Yes, there are no fields in x-axis.
But the question was about a "multiple" question (see Kristines screenshot), not an array.
And this also happens in y-axis of arrays.

Joffm

To add: It is not necessary to "Save and close", "save" is sufficient.


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Last edit: 5 months 4 days ago by Joffm.

Please Log in to join the conversation.

More
5 months 4 days ago - 5 months 4 days ago #231394 by tpartner

Yes, there are no fields in x-axis.
But the question was about a "multiple" question

Yes, I focused on the thread title which seems to indicate columns in arrays.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last edit: 5 months 4 days ago by tpartner.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now