New version - bug

More
2 weeks 5 days ago #222161 by scene143
New version - bug was created by scene143
Hi Team,

Yesterday my limesurvey got updated and i got 5.22.Itseems simple formula also not working correctly.

I am trying this formula to put it in Subquestion > relevance equation = Q1_SQ001=="Y" OR Q2_SQ001=="Y" OR Q3_SQ001=="Y" in code 1 after i paste this formula and saved..again opened the same and checked but not getting complete formula.

Also this formula is not working like previous version.

Attached the sample survey and the screenshot can you please help me on this.


Regards
Sara
Attachments:

Please Log in to join the conversation.

More
2 weeks 5 days ago #222171 by holch
Replied by holch on topic New version - bug
Do not send LSQ files, always send LSS files when you want help. LSQ files are language sensitive and it requires a lot more work from the helpers in the forum (create a survey with the correct language, create a question group, import the question, hope you got the correct base language). Also, some problems come from general settings in the survey.

Therefore, make a copy of your survey, delete all unnecessary "clutter", leave only the questions that are relevant for the problem and then export this survey.

In your case the LSQ file wouldn't help much anyway, because your problem actually refers to a series of other questions like Q1, Q2 and Q3. Without these questions in the LSS file, how are we supposed to debug???

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
2 weeks 5 days ago - 2 weeks 5 days ago #222174 by Joffm
Replied by Joffm on topic New version - bug
Hi, Sara,
please never send lsq or lsg exports, only lss.
Reason:
1. lsq and lsg exports are language sensitive. You can only import them into a survey with the same base language as the export.
2. We have to create a survey - hopefully with the correct base language, create a group to be able to import the question.

So, please, ease our life.

Well, when I do all this I only see a question without subquestion relevance.
 

Please, send the full survey, or copy it, remove everything not related to the problem, and send this as lss.

Joffm

EDIT: @holch was faster.
 


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:
Last edit: 2 weeks 5 days ago by Joffm.

Please Log in to join the conversation.

More
2 weeks 5 days ago #222179 by holch
Replied by holch on topic New version - bug

EDIT: @holch was faster.


Too slow my friend, too slow. ;-)

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
2 weeks 5 days ago #222186 by scene143
Replied by scene143 on topic New version - bug
Hi Joffm,

Sorry for that.

Here the LSS file attached.

In my laptop it only half of the formula is showing dont know why that too is not showing at your end.

Regards
Sara
Attachments:

Please Log in to join the conversation.

More
2 weeks 5 days ago #222188 by Joffm
Replied by Joffm on topic New version - bug
Hi,
I could reproduce it, even in 5.2.1.
Seems to be a bug in the editor.
You save it, run the survey and it works.
But if you open the editor again the "Y" is gone.

But with single quotes it is fine 'Y'.





Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:

Please Log in to join the conversation.

More
2 weeks 5 days ago #222190 by scene143
Replied by scene143 on topic New version - bug
Thank you Joffm.

Please Log in to join the conversation.

More
2 weeks 5 days ago #222192 by tpartner
Replied by tpartner on topic New version - bug
Please file a bug report.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
2 weeks 4 days ago #222214 by jelo
Replied by jelo on topic New version - bug
bugs.limesurvey.org/view.php?id=17734
Wrong version submitted.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now