PDF-Export: Radio list not fully visible in PDF

More
3 months 1 week ago - 3 months 1 week ago #201297 by ann0see
Hi,

I am quite new to LimeSurvey and have a problem with PDF-Export.

I use LimeSurvey Version 4.2.8+200608 on Firefox/Edge.

If I choose the questiontype radio or anything with (L) exported PDF files only show the first answer option while the others are hidden.

If I view it online, everything is as it should be.

Of course this isn't what I want. Is it possible to show all the other options in the PDF export too? Maybe I have to set something differently? To solve the problem I currently use the matrix question type which isn't really what I want (the text gets to small since the answers are quite long).
Attachments:
Last edit: 3 months 1 week ago by ann0see. Reason: Added pictures

Please Log in to join the conversation.

LimeSurvey Partners
More
3 months 1 week ago #201300 by holch
LS 4.x has still a lot of bugs, I would recommend to use 3.x for the moment. 4.x only for testing and bug reporting.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
3 months 1 week ago #201301 by ann0see
Ok. It says that 4.* is the latest stable version?
Nevertheless, is it possible to downgrade to version 3.* without bigger problems?

Please Log in to join the conversation.

More
3 months 1 week ago #201302 by holch
It said that 4.x is the latest stable version. Since today it says that 4.x is the "latest"... ;-)

And "stable" is very relative. Most volunteers here in the forum have been preaching to stay with 3.x for now, even with 4.x being labeled as stable. Because we felt that it is not stable or not stable enough.

Unfortunately there is no way to downgrade (due to changes in the database) and there is also no way to import surveys from 4.x to 3.x LTS.

Sorry, I don't have better news...

And: Please report the bug in 4.x (bugs.limesurvey.org).

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.
The following user(s) said Thank You: ann0see

Please Log in to join the conversation.

More
3 months 1 week ago #201303 by ann0see
Ok. Just downgraded.
I will report the bug.
Will probably have to put all my surveys in by hand.

Please Log in to join the conversation.

More
3 months 1 week ago #201304 by holch
The upgrade later should be no problem, once LS 4.x is "more stable".

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
3 months 1 week ago #201311 by ann0see
Sorry, but I can't report the bug because my limesurvey account is connected to github and I don't have a password setup. Could you please report it?
You can link this thread.
Thanks!

Please Log in to join the conversation.

More
3 months 1 week ago #201312 by holch
Reporting bugs that you don't experience is always tricky, because I don't really have an experience with it, but I will try.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
3 months 1 week ago #201313 by ann0see
Thanks! You can of course say that it was experienced by me (and link this thread).

Please Log in to join the conversation.

More
3 months 1 week ago #201315 by holch
This is not the normal PDF Export, but the QueXF Export, right?

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
3 months 1 week ago #201317 by holch

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
3 months 1 week ago - 3 months 1 week ago #201385 by ann0see
Thank you! Yep. It's the QueXF PDF export
Last edit: 3 months 1 week ago by ann0see.

Please Log in to join the conversation.

More
3 months 1 week ago #201387 by holch
The bug was already confirmed by one of the developers. New status "confirmed".

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now