ComfortUpdate to Version stable 4

More
1 year 8 months ago #193039 by lfanfoni
Hello everyone. First of all thanks for the work done with version 4.
I checked the possible updates to the stable 4 with the ComfortUpdate. I tried from version 3.21.6 + 200121 and from 4.0.0-beta + 190509. In both cases, the system replies that no update is available for that version. Am I therefore forced to install a stable version 4 from scratch, or is there a direct update in the coming days?
Thank you
Luciano

Se mi vuoi contattare, non mandare messaggi privati qui, bensì scrivi a lfanfoni at gmail.com
Per le livestream in italiano vai su: www.youtube.com/playlist?list=PLOSjjxAG9...SiiCsSz_JxIH7xJwLdPd
Le soluzioni LimeSurvey per l'Italia si trovano su: github.com/lfanfoni
The topic has been locked.
More
1 year 8 months ago #193059 by jelo

Am I therefore forced to install a stable version 4 from scratch, or is there a direct update in the coming days?

Currently no comfortupdate to LS4.X. There is no release date for Comfortupdate. So it can take a few days or a few weeks.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
The following user(s) said Thank You: DenisChenu
The topic has been locked.
More
1 year 8 months ago #193064 by DenisChenu
> from 4.0.0-beta + 190509.

Maybe this need to reported ?
4.X can update to 4.X :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
1 year 8 months ago #193073 by lfanfoni
Honestly, I would have preferred to update the 3.X comfortably rather than the 4 beta

Se mi vuoi contattare, non mandare messaggi privati qui, bensì scrivi a lfanfoni at gmail.com
Per le livestream in italiano vai su: www.youtube.com/playlist?list=PLOSjjxAG9...SiiCsSz_JxIH7xJwLdPd
Le soluzioni LimeSurvey per l'Italia si trovano su: github.com/lfanfoni
The topic has been locked.
More
1 year 8 months ago - 1 year 8 months ago #193076 by DenisChenu

Honestly, I would have preferred to update the 3.X comfortably rather than the 4 beta

Can you explain ?

Bug (that must be corrected, and OK with a beta) or bad user experience ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
Last edit: 1 year 8 months ago by DenisChenu.
The topic has been locked.
More
1 year 8 months ago #193078 by lfanfoni
Since the 3.X suddenly became LTS, I think it makes more sense to provide the ComfortUpdate from 3.X to 4 stable, rather than from 4 beta to 4 stable. I think most people with 3.X platform with ongoing production processes need to easily switch to the new updated version (4)

Se mi vuoi contattare, non mandare messaggi privati qui, bensì scrivi a lfanfoni at gmail.com
Per le livestream in italiano vai su: www.youtube.com/playlist?list=PLOSjjxAG9...SiiCsSz_JxIH7xJwLdPd
Le soluzioni LimeSurvey per l'Italia si trovano su: github.com/lfanfoni
The topic has been locked.
More
1 year 8 months ago #193079 by DenisChenu
Currently ther are 2 major issue's for upgrading via ComfortUpdate

1. Survey Theme can broke
2. A lot of plugins broke
3. Question Theme didn't work as expected.

I rarely see another tool allowing major update easily just one month after.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
1 year 8 months ago #193082 by lfanfoni
I agree: we have rarely seen a tool allowing important updates in a short time. And much has been done to get to this version. It is important in my opinion, however, to give information on whether or not there will be a ComfortUpdate from 3.X to 4, in the right time to guarantee total portability.

Se mi vuoi contattare, non mandare messaggi privati qui, bensì scrivi a lfanfoni at gmail.com
Per le livestream in italiano vai su: www.youtube.com/playlist?list=PLOSjjxAG9...SiiCsSz_JxIH7xJwLdPd
Le soluzioni LimeSurvey per l'Italia si trovano su: github.com/lfanfoni
The topic has been locked.
More
1 year 8 months ago #193211 by holch
I assume (without having any official confirmation) that the upgrade from 3.x to 4.x in Comfort Update will come. However, as Denis says, there are probably some issues that might prevent a seemless upgrade yet, so the Limesurvey GmbH will most probably work on this. But in any way, as a client of Limesurvey GmbH it is probably the safest bet to create a support ticket and ask them the question directly, because most of us here are "only" part of the community, while Comfort Update is a premium feature provided by Limesurvey GmbH. So only they will really know, if, when and how CU will be able to update from 3.x to 4.x.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.
The following user(s) said Thank You: DenisChenu
The topic has been locked.

Start now!

Just create your account and start using Limesurvey today.

Register now