Allow multiple responses OR update responses with one token?

More
3 years 2 months ago #175075 by jlwood
Thank you for working on this Denis. I've been trying to use your plugin for a problem like the OP's but haven't been able to make it work. Could you explain how I should set up the first survey? Here's what I've done:
I installed and activated the questionExtraSurvey plugin.
I have a survey named "CWP" where participants need to be able to create new records and edit their previous records.
I've created a new survey with tokens for participants called "CWPMaster" and added 1 group with 1 textdisplay field named "addOrEdit". but I don't see any way to indcate which survey to connect to or any other plugin config

Sorry if I am missing the obvious
The topic has been locked.
More
3 years 2 months ago #175082 by DenisChenu

but I don't see any way to indcate which survey to connect to or any other plugin config

In the advanced settings of a long text or text display question : you find new attributes.

Remind this plugin was never tested in 3.X version

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
3 years 2 months ago #175154 by jlwood
I'm not seeing any new attributes. I'm using Version 2.06+ Build 160129. Only the usual settings appear under Advanced Settings. The Plugin manager shows questionExtraSurvey as being enabled, but it must not be working properly on my system. I don't know of any way to check and see if it is actually loading properly.
The topic has been locked.
More
3 years 2 months ago #175159 by DenisChenu

I'm not seeing any new attributes. I'm using Version 2.06+ Build 160129.

Not compatible : ls2.6+ didn't have question attribute by plugin.

You can try with my fork : github.com/SondagesPro/LimeSurvey-Sondag...f7903d4bdbf4575ca07d but REALY no warranty of functionnality …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.
More
3 years 2 months ago #175197 by jlwood
That would explain things. I think I'd rather upgrade our install instead of going with the fork. This is a good time for us to upgrade and I've been intending to do it anyway. I think version 2.73.1-build171220 is the most recent LS2 lts package, though it's hard to tell from the web site. That version is supported by the plugin?
The topic has been locked.
More
3 years 2 months ago #175198 by DenisChenu
Tested : LimeSurvey 2.64 and LimeSurvey 3.8

2.73.1 is NOT a lts … no lts currently

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.
The topic has been locked.

Start now!

Just create your account and start using Limesurvey today.

Register now