Choice experiment: Randomly select one choice

More
2 months 4 weeks ago #215351 by s_sinning
The code changed itself because there was a mistake but after deleting the "/survey" part from the code you just sent it finally worked. Thank you so much I am really really grateful for your help!!

Please Log in to join the conversation.

More
2 months 4 weeks ago #215362 by s_sinning
After having thought that I am finally done, I am facing a new problem now: While the survey looks good in Safari, it seems that not all pictures are shown in other browsers.   Is there something I did wrong? 
Attachments:

Please Log in to join the conversation.

More
2 months 3 weeks ago #215400 by s_sinning
This is how it looks on Google Chrome for example. (Before & after upgrading to Version 3.23.6+200929)
Attachments:

Please Log in to join the conversation.

More
2 months 3 weeks ago #215401 by Joffm
Are the images existing?

This is the sourcecode
<img alt="" src="/lime3/upload/surveys/792748/images/C10_1.png" style="width:341px;height:200px;" />           
<img alt="" src="/lime3/upload/surveys/792748/images/C10_2.png" style="width:341px;height:200px;" />
<img alt="" src="/lime3/upload/surveys/792748/images/C2_1.png" style="width:435px;height:254px;" />              
<img alt="" src="/lime3/upload/surveys/792748/images/C2_2.png" style="width:435px;height:254px;" />
<img alt="" src="/lime3/upload/surveys/792748/images/C2_1neu.png" style="width:415px;height:241px;" />            
<img alt="" src="/lime3/upload/surveys/792748/images/C2_2neu.png" style="width:415px;height:241px;" />        

Do care about the filepath. It's the one in my local system.
 
But anyway: You should set the width of all images to a fixed size.
Here some screens where I displayed the images in a table.
And I do not see any issue.
Neither in Chrome
   

nor in Firefox
 

nor in IE11.



 


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:

Please Log in to join the conversation.

More
2 months 3 weeks ago #215552 by s_sinning
I am sorry can I bother you one last time? 
If I test the survey everything works as I want it (no matter if I try it with my phone or with my laptop).
However, if I sent it to friends to test the survey they do not get to see the payoff after finishing the choices. Since it works well for me however, it is really hard to find what the problem is and I really don't know where to look at anymore...
Is there any mistake I did in my code? 

PS: Here is the link to the activated survey:  ceres.parisdescartes.fr/index.php/915951?lang=en
Attachments:

Please Log in to join the conversation.

More
2 months 3 weeks ago #215557 by holch
I won't get into if some of those options could be excluded because they don't make much sense (in my opinion), I went through what felt like thousand choices ;-) and I got to see the payoff. What I noticed is that the server seems to be a little slow, but else things worked fine (tested with the latest chrome on Windows 10).

You need to check with your friends what type of setup they have (OS, Browser, behind a firewall / proxy, etc).

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

Please Log in to join the conversation.

More
2 months 3 weeks ago #215617 by s_sinning
I get this feedback (i.e., that the payoff is not working) from people using Mac or Windows, Safari or Chrome, based in France or Germany. I really don't understand what the issue is...

Please Log in to join the conversation.

More
2 months 3 weeks ago #215618 by jelo

I get this feedback (i.e., that the payoff is not working) from people using Mac or Windows, Safari or Chrome, based in France or Germany. I really don't understand what the issue is...

The first thing is to get more infos about what not working acutally means.
The payoff is only consisting of an graphic on the page. So what do the people see on the page?
Could it be that a adblocker is in place and blocks the image?

I recommend to ask one of tester to repeat the survey, but to always choose the None option.
That way you can ensure they get the same image at the end. If that is working, you have the issue not on all payoffs.

BTW:On your first page, you write DSGV.  In German it would be DSGVO and GDPR in English.

in compliance with the DSGV.

When doing choice tasks, I recommend to number them, to show progress e.g. 1 of 12 2 of 12 3 of 12. If not, you will see higer churn during that task.
 

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in to join the conversation.

More
2 months 3 weeks ago #215619 by jelo
I looked at the survey file. If I look at Q-53 Q-54 and Q-55 which are creating the eqChoice for
<img alt="Payoff" src="/upload/surveys/915951/images/{eqChoice}.png" style="width:415px;height:241px;" /> it's hard to debug if there is combination where the filename might not be valid.

For debuggin purpose I would recommend to show the filename as text in the question and let tester report that page back if they don't see the payoff.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now