SPSS data and syntax import issue on MacOS

More
3 months 3 weeks ago #207888 by blocka
When I try to import my data file, I get these error:

Failure to open file: ... _SPSS_data_file.dat
This command is not valid before a working file has been defined
This command dis not permitted before the beginning of the file definition.

etc....

This is on MacOS, and I've updated the syntax file to point to the path for my data file, like:
/FILE=Folder1/Folder2/SPSS_data_file.dat

Any one have some suggestions?

Please Log in to join the conversation.

LimeSurvey Partners
More
3 months 3 weeks ago #207891 by Joffm
This is an issue of Mac OS Catalina and SPSS.
Read here
www.ibm.com/support/pages/working-ibm-sp...stics-macos-catalina

Data files
Due to changes in the way macOS Catalina handles new file/directory access, IBM SPSS Statistics is not able to open data files using the file chooser or the GET FILE command.

Note: This issue is resolved starting with IBM SPSS Statistics 26.0 Fix Pack 1 (available end of October, 2019).


How I would work around it?
Export data as *.csv and spss.
Import the *.csv by "File / Read text" (I don't know exactly; I have a German GUI of SPSS)
Use the syntax file of the SPSS export to adapt and set the VARIABLE and VALUE LABELS.

Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless

Please Log in to join the conversation.

More
3 months 1 week ago #208284 by tixeon
I had this same problem on Windows. I tried updating the path but it never worked. In the end I got it to work by pasting the *.dat file into the SPSS directory (IBM>SPSS>Statistics>24). (the syntax file can sit anywhere).

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now