Hidden sub-questions with default answers

More
1 month 4 weeks ago #199324 by giorgio-pap
Hi,


I am having an issue with a Multiple short text (survey attached).

I have one question group (A) with multiple sub-questions, two of these are hidden but have default answers.

When I export the results in csv, I see the the hidden coordinates variables as a column, but those two columns are empty.

How can this be fixed?
Attachments:

Please Log in to join the conversation.

LimeSurvey Partners
More
1 month 4 weeks ago #199326 by tpartner
How did you hide the sub-questions?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Please Log in to join the conversation.

More
1 month 4 weeks ago #199327 by Joffm
Hi,
of course they are empty.
The elements with relevance "0" are not posted.

Either you hide these two subquestions by javascript or - the easy way -
set the values by a hidden question of type equation after this question.
{A_EUR="7"}
{A_Leistung="This is fixed"}

By the way: What is the reason to have two hidden elements with constant values?

I revise your question text and the validation.
In my opinion it's not the best to show initially an error.

File Attachment:

File Name: limesurvey..._rev.lss
File Size:21 KB


Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now