Welcome to the LimeSurvey Community Forum

Ask the community, share ideas, and connect with other LimeSurvey users!

Error in data set after downloading

  • zliine
  • zliine's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 2 months ago #216413 by zliine
Error in data set after downloading was created by zliine
Dear all,

I downloaded my data set as CSV file and had a first look at it in Excel. I noticed the following error:
The question is in the "dual matrix" format with the following answer options and codes...
Antwort-Skala 1, A1 = in der Gegenwart
Antwort-Skala 2, A2 = in der Vergangenheit
this means, that each "Skala" only has one possible answer, however, in my data set, I see that under "Skala 1" the answers A1 AND A2 appear, and the same happens for "Skala 2". See the screenshots attached for clarification. Can someone explain why it shows A1 and A2 although only one option should be available per "Skala" ? This messes up my whole data set.

All the best,
Celine
The topic has been locked.
  • Joffm
  • Joffm's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
3 years 2 months ago - 3 years 2 months ago #216415 by Joffm
Replied by Joffm on topic Error in data set after downloading
Hi,
Are these codes in the LimeSurvey answer table, too?

Joffm

And you missed to mention your LS version and where hosted.

 

Volunteers are not paid.
Not because they are worthless, but because they are priceless
Last edit: 3 years 2 months ago by Joffm.
The topic has been locked.
More
3 years 2 months ago #216419 by jelo
Replied by jelo on topic Error in data set after downloading
My first guess would be an import issue with CSV and Excel (where the regional list separator is not matching the CSV format).

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
The topic has been locked.
  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
3 years 2 months ago #216424 by holch
Replied by holch on topic Error in data set after downloading
I go with Jelo!

How does the same section look like in the Limesurvey backend where you can see the responses?

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

The topic has been locked.
  • zliine
  • zliine's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 2 months ago #216467 by zliine
Replied by zliine on topic Error in data set after downloading
Dear all,
I checked and the error appears in the LimeSurvey answer table too. For some answers, it's correct and for others it's not (see screenshots attached).
I use LiemSurvey Version 3.26.2 210503 (?) hosted in Germany.

All the best,
Celine
The topic has been locked.
  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
3 years 2 months ago #216473 by holch
Replied by holch on topic Error in data set after downloading
Hmm, your second screenshot looks odd. Why does Limesurvey show the answerlabel and the answer code in the first column, but not in the second column?

Because for the first screenshot the table shows label and code for both, but in the second one, where there are problems, it only shows the code.

Do you have any equations in your survey? My suspicion is that you have an error in the your equation and instead of checking if the answer is A2 you attribute A1 to the answer via equation.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

The topic has been locked.
  • Joffm
  • Joffm's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
3 years 2 months ago #216475 by Joffm
Replied by Joffm on topic Error in data set after downloading
Hi, Celine,

in this case you have to send the survey as lss export. (only these relevant questions)

You see the differences in your two screenshots.
In the first one, which is correct, there is the answer code and the answer text displayed
But in the second there is only the wrong code ("A1") displayed; but no text.

This we have to find out.

Joffm

Volunteers are not paid.
Not because they are worthless, but because they are priceless
The topic has been locked.
  • zliine
  • zliine's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 2 months ago #216481 by zliine
Replied by zliine on topic Error in data set after downloading
Dear Joffm,

I'm sorry, I don't know how I export only the relevant questions as lss. Attached you'll find the whole survey as lss and the relevant question as lsg. I haven't checked yet, if the problem also appears in the other dual matrices in the study though.
Thanks for the help, I really appreciate it :-)
The topic has been locked.
  • zliine
  • zliine's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
3 years 2 months ago #216482 by zliine
Replied by zliine on topic Error in data set after downloading
I do have a lot of equations in the study but they are all correct, I double checked them and did the survey myself a few times and everything is portrayed as it should be.. (except the exported data though)
The topic has been locked.
More
3 years 2 months ago - 3 years 2 months ago #216484 by jelo
Replied by jelo on topic Error in data set after downloading
I have reduced the survey to the part of the screenshots. LS4 format.



 

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Last edit: 3 years 2 months ago by jelo.
The topic has been locked.
More
3 years 2 months ago #216491 by jelo
Replied by jelo on topic Error in data set after downloading
L3 Format.

I cannot reproduce the issue under LS Version 3.26.5+210519.

My reduced surveys have ExpressionScript relevance instead of the conditions via designer.

Currently it looks like a bug (perhaps with certain browsers, perhaps with certain Limesurvey versions.
The array dualscale type is not used that often.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
The topic has been locked.
  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Community Team
  • LimeSurvey Community Team
More
3 years 2 months ago #216496 by holch
Replied by holch on topic Error in data set after downloading

I do have a lot of equations in the study but they are all correct,


Well, there seem to be a couple of relevance equations that are slightly different to others (e.g. spaces, etc), when looking at them in the LSS file. For example this one:

 

There are some "((" and "))" missing compared to the others and there are also some spaces, that can't be found with the others. But I don't know what impact this would have, I would guess none. I doubt that this is the problem.

I was more looking for some real equations (not relevance equations), that might have somethink linke Qcode="A1" or something, where one "=" would be missing and thus redefine the answer instead of comparing it.

But I couldn't find any of those instances in the LSS and there also seem to be no equations referring to the question from the screenshot anyway.

So I guess we can rule this out as the source of the problem.

I answer at the LimeSurvey forum in my spare time, I'm not a LimeSurvey GmbH employee.
No support via private message.

The topic has been locked.

Lime-years ahead

Online-surveys for every purse and purpose