Question is corrupt: no type defined for question

More
2 years 2 months ago - 2 years 2 months ago #165045 by jorge_ici
Saudações!

Há cerca de uma semana que me confronto com o erro que se segue, após tentar criar uma nova questão num novo questionário:

"Erro Interno Do Servidor. Question is corrupt: no type defined for question 311. Ocorreu um erro interno enquanto o servidor Web processava sua requisição. Por favor entre contate the webmaster para relatar esse problema."

Pensei que a atualização resolveria o problema e efetuei-a hoje para a versão 3.4.4+180305. Porém, o problema persiste.

Alguém já teve o mesmo problema e resolveu-o?
Qualquer ajuda é bem-vinda.

Obrigado e bom trabalho para todos,
JR
Last edit: 2 years 2 months ago by jorge_ici.

Please Log in to join the conversation.

LimeSurvey Partners
More
2 years 2 months ago #165049 by holch
Apaga a pergunta 311 e cria ela de novo.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 2 months ago #165050 by jorge_ici
Não dá. Deixo de ter acesso ao questionário, ou seja, quando o tento abrir sou remetido para a mesma mensagem de erro.
Nessa sequência, apago o questionário, crio um novo e, após criar a primeira pergunta, recebo a mesma mensagem de erro.

Please Log in to join the conversation.

More
2 years 2 months ago #165053 by holch
Hmm, estranho. Você já tentou copiar o questionário? As vezes tem algum problema pequeno, que se resolve assim. Mas, se você cria um questionário novo e aconteçe o mesmo problema, pode ser algo mais grave com a sua instalação.

Mas a mensagem de erro muda (o número da pergunta?), certo?

Sempre é o mesmo tipo de pergunta que causa o problema?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #165056 by jorge_ici
Sim, já copiei o questionário, mas o erro vai atrás...
Sim, na mensagem de erro vai mudando o número da pergunta, conforme vou criando novos questionários...
Excelente a terceira questão: acabei de verificar que é apenas com perguntas de escolha múltipla > Lista de seleção (dropdown). Recebi de novo a mensagem:
"Question is corrupt: no type defined for question 325"
Depois de receber este erro, já não consigo aceder mais ao questionário!
Last edit: 2 years 2 months ago by jorge_ici.

Please Log in to join the conversation.

More
2 years 2 months ago #165059 by holch
OK. Isso já nos ajuda em determinar onde está o problema.

Agora temos que determinar se isso é apenas um problema da sua instalação ou se isso é um bug e precisa um bug report. Infelizmente no momento não posso testar na minha instalação de 3.4.x. Vou ver se consigo fazer isso hoje a tarde.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 2 months ago #165060 by jorge_ici
Excelente. Muito grato!

Please Log in to join the conversation.

More
2 years 2 months ago #165064 by holch
Estou tentando de recrear seu problema aqui, mas estou com uma dúvida, qual é o tipo de pergunta extamente?

Porque para mim as perguntas "multipe choice" não tem a opção de dropdown. Você se refere a "Single Choice" --> List (dropdown)?

Você se refere a este tipo de pergunta? Caso que sim: Funciona para mim sem problema em 3.4.4.


I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Attachments:

Please Log in to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #165065 by jorge_ici
Peço imensas desculpas. Tem toda a razão. É de facto na opção «Perguntas de escolha única». Peço desculpas mais uma vez.
Assim sendo, parece que o problema poderá estar em alguma configuração específica minha. Não faço ideia qual poderá ser... alguma ideia?
De facto, quando seleciono a opção «Lista de seleção (dropdown)» o painel fica assim (no tipo de pergunta, em vez de «Lista de seleção (dropdown)» fica a opção «Texto livre longo»)...

Attachments:
Last edit: 2 years 2 months ago by jorge_ici.

Please Log in to join the conversation.

More
2 years 2 months ago #165066 by holch
Acho que houve algum problema na hora de instalar. Você tem muitos questionarios ou foi instalado recentemente? Se for instalado recentemente, eu instalaria de novo, tendo cuidado que todos os arquivos sejam subidos corretamente.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #165067 by jorge_ici
Eu já instalei há mais de um ano e tem corrido tudo bem. Tenho cinco questionários ativos (e oito desativados). Mas agora que quero criar um novo, começou a dar este erro.
Last edit: 2 years 2 months ago by jorge_ici.

Please Log in to join the conversation.

More
2 years 2 months ago #165068 by holch
Se não quer instalar de novo, faça um bug report. Porque acho que apenas desta forma isso pode ser resolvido, se existe solução.

Eu não sei mais o que fazer neste caso.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 2 months ago #165071 by jorge_ici
Compreendo e agradeço o seu apoio.
Apenas receio que uma nova instalação implique perder os questionários que tenho ativos (bem como os outros que deram imenso trabalho a construir).
Espero que alguém me possa indicar quais serão os ficheiros necessários para repor a opção «Lista de seleção (dropdown)» dado que quando a escolho, nem sequer surge o exemplo que supostamente deveria surgir no lado direito da janela...
Attachments:

Please Log in to join the conversation.

More
2 years 2 months ago #165078 by holch

jorge_ici wrote: Compreendo e agradeço o seu apoio.
Apenas receio que uma nova instalação implique perder os questionários que tenho ativos (bem como os outros que deram imenso trabalho a construir).


Entendo perfeitamente. Mas os questionários não precisam ser perdidos. Você pode exportar os questionários como arquivo .LSS, que é a estrutura do questionario ou .LSA que até inclui as respostas. Você pode importar estos arquivos na nova instalação.

Claro, se tem pesquisas ativas e pessoas respondendo, uma instalação nova é um pouco problematica, mas o bom do Limesurvey é que você não paga licencia. Você poderia instalar de novo em paralelo, sem apagar a instalação antiga e fazer um teste, se melhorou. De aí você muda os questionarios na nova instalaçao pouco a pouco.

Espero que alguém me possa indicar quais serão os ficheiros necessários para repor a opção «Lista de seleção (dropdown)» dado que quando a escolho, nem sequer surge o exemplo que supostamente deveria surgir no lado direito da janela...


De que versão você fez o update? Até que versão as coisas funcionaram sem problema? Qual é a primeira versão que causo o problema? Pode ser que os tipos de perguntas não foram bem instaladas.

Você tem como exportar um dos questionarios problematicos e postar aqui? Ou mandar por mensagem pessoal, caso que não queira compartilhar no forum? Ai eu faço uma importação para ver que aconteçe.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #165092 by jorge_ici
No próximo fim de semana irei tentar a instalação paralela.

De que versão você fez o update? Até que versão as coisas funcionaram sem problema? Qual é a primeira versão que causo o problema? Pode ser que os tipos de perguntas não foram bem instaladas.

Penso que o problema vem de há duas versões (estáveis) atrás. Algo correu mal com o Comfort Update, mas depois correu bem (aparentemente, pelos vistos não) com o update via Softaculous (que é por onde estão agora os updates programados, automaticamente).

Você tem como exportar um dos questionarios problematicos e postar aqui? Ou mandar por mensagem pessoal, caso que não queira compartilhar no forum? Ai eu faço uma importação para ver que aconteçe.

Não tenho como exportar porque uma vez recebida a mensagem de erro, perco o acesso total às opções do questionário, exceto à da sua eliminação.

Muito grato pelo seu apoio.
Last edit: 2 years 2 months ago by jorge_ici.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now