impossible de télécharger les fichiers joints

More
2 months 1 week ago - 2 months 6 days ago #229124 by Castella
Bonjour,J'ai la version 5.3.18 220530 installée sur un serveur mutualisé (Infomaniak). J'ai créé une question pour envoyer des fichiers (je souhaite des pdf). Mais impossible de les retrouver facilement (si je vais dans les réponses, il y a bien le lien, mais il ne se passe rien sur Firefox et sur Chrome, il y a pour finir l'indication de fichier corrompu. Si je télécharge la réponse sous forme de fichier zip, c'est la même chose : impossible d'ouvrir le zip (également mention fichier corrompu). Si je vais dans la base de donnée, j'arrive retrouver le fichier (grâce à la date, car le nom n'a rien à voir) et si j'ajoute l'extension pdf, je peux enfin le voir (pas du tout corrompu). Pas pratique du tout. Est-ce qu'il y a une solution à cette situation ?Et autre question, si on peut résoudre ce problème, est-il alors possible de joindre ce ou ces fichiers à la notification détaillée à l'administrateur ? En mentionnant le nom du champ, ça ne donne rien d'utilisableMerci d'avance,Cédric
Attachments:
Last edit: 2 months 6 days ago by Castella. Reason: Correction mineure et précision de la question + envoi d'une autre capture d'écran

Please Log in to join the conversation.

More
2 months 3 days ago - 2 months 3 days ago #229174 by DenisChenu
Tu peux activer le mode debug ?
manual.limesurvey.org/Debug_mode
Et nous indiquer l'erreur remontée ?

En cliquant avec le bouton droit et "Ouvrir dans une nouvelle fenêtre" sur les liens.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
I don't answer to private message.
Last edit: 2 months 3 days ago by DenisChenu.

Please Log in to join the conversation.

More
2 months 2 days ago #229262 by Castella
J'ai essayé, mais rien ne se passe (ou alors je ne sais pas où trouver les informations. Sous Firefox, l'onglet s'ouvre, aucun message d'erreur n'apparaît et le fichier ne se charge pas. Sous Chrome, la seule chose qui change est l'apparition d'un message "fichier invalide ou corrompu" (même sans avoir activé le mode debug).

Please Log in to join the conversation.

More
2 months 2 days ago #229268 by DenisChenu
Sans mode debug ca va être plus difficile.
Tu as accès au log d'erreur du serveur ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
I don't answer to private message.

Please Log in to join the conversation.

More
2 months 2 days ago #229269 by Castella
Je ne suis pas sûr, c'est un serveur mutualisé (et je ne suis pas très calé dans ce domaine). En tout cas j'ai un accès FTP complet et également accès aux bases de données. Et si nécessaire, je pense qu'Infomaniak peut me transmettre ces données.

Please Log in to join the conversation.

More
2 months 2 days ago #229270 by DenisChenu
Donc : le plus simple serait de passer en mode debug.
Pourquoi ne pas le faire ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
I don't answer to private message.

Please Log in to join the conversation.

More
2 months 1 day ago #229278 by Castella
Mais je l'ai fait... Mais je n'ai obtenu aucun message. Je m'y prend sans doute mal. J'ai mis limesurvey en mode debug, puis comme proposé, j'ai été dans les réponses du qestionnaire et j'ai fait un clic droit sur le lien vers le fichier téléchargé pour l'ouvrir dans un nouvel onglet et ... rien (l'onglet s'ouvre mais aucun fichier n'apparait et sur Chrome il y a juste l'indication que le fichier serait corrompu. Seule possibilité : le retrouver dans la base de données, lui rajouter l'extension pdf et là, il apparaît. Mais ça n'est pas une solution acceptable.

Please Log in to join the conversation.

More
2 months 1 day ago #229280 by DenisChenu
Désolé …
Mal compris …

Bin : aucune idée là … je devrais résoudre le problème j'ajouterais des print_r et tracevar …
Mais sans pouvoir bidouiller le code en direct : aucune idée.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
I don't answer to private message.

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now