[Résolu] Question conditionnée à un attribut de participant

More
7 months 1 week ago #193860 by dbourrion
Bonjour.
J'ai besoin d'un questionnaire qui serait utilisé dans un cadre de vote, avec certaines questions visibles seulement par certaines personnes, en fonction de leur appartenance (ou non) à un "collège" de votants.

J'ai donc ajouté un attribut "Collège" sur les participants.
Je me suis mis dans les participants en indiquant que je suis en collège=B

Je vais sur une question, je choisis en condition "Attributs des participants" et j'indique dans "Constante" (qui est vide) A pour me cacher ladite question.
J'enregistre. Je teste. Je vois bien la question alors que du fait de mon attribut "B" je ne devrais pas la voir.
Dans la conf de ladite question, j'ai bien Équation du filtre conditionnel : ((112565X3093X38561.NAOK == "A"))

Je ne comprends pas ce qui merdouille.
Une piste ?
Merci par avance.
D.

Please Log in to join the conversation.

LimeSurvey Partners
More
7 months 1 week ago - 7 months 1 week ago #193862 by dbourrion
Problème réglé en utilisant l'outil "Ajout rapide de conditions" au lieu de l'ajout standard.
Aucune idée du pourquoi ça marche en ajout rapide et pas en ajout normal, mais peu importe.
Last edit: 7 months 1 week ago by dbourrion. Reason: Ajout mention de résolution
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
7 months 1 week ago #193909 by DenisChenu
Perso, j'utiliserais le texte manuel : encore moins d'erreur possible.

Sinon, version de LimeSurvey ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development . I don't answer to private message.

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now