ComfortUpdate with MS SQL Server

More
3 years 10 months ago #141410 by medhat
Hi Guys,

I'm running lime version 2.00+ with MS SQL Server DB over IIS and would like to upgrade to 2.06 lts.

Is it safer/better to upgrade manually or using ComfortUpdate? (as I want to avoid ending-up with a missing data or a crashed version).

Appreciate your help.


Regards,
Medhat
The topic has been locked.
LimeSurvey Partners
More
3 years 10 months ago #141416 by jelo
I don't think 2.00+ offers Comfortupdater. If you be offered updates inside the Admin-GUI of Limesurvey feel free to use that option.
I don't see any pro and cons relating to MS SQL Server. It is the old version of LS which might prevent a smooth upgrade.

To get the LTS version as a release from LS GmbH you will need to buy a comfortupdate key. Without that key you will need to download LTS via other ways (like GIT).

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
The topic has been locked.
More
3 years 10 months ago #141431 by medhat
Thanks jelo for your reply.

Actually the "Use ComfortUpdate" button is there, but when I tried it I got "Internal Server Error Property "update.updaterversion" is not defined"!
I know there is a fix on bugs.limesurvey.org/view.php?id=9064 , but I'm afraid that things will not run smoothly, as you guessed!

I've also tried testing the manual upgrade, my templates were not copied so I had to copy and assign them manually to my old surveys.

Ending-up with some issues in both ways, I thought of getting some feedback for the great LS community on the easier & safer way to upgrade.
The topic has been locked.
  • LouisGac
  • LouisGac's Avatar
  • Visitor
  • Visitor
3 years 10 months ago #141436 by LouisGac
Replied by LouisGac on topic ComfortUpdate with MS SQL Server
2.00 use the old comfortUpdate, which is kinda buggy.
I'd recommend a manual update (not very hard).
The topic has been locked.

Start now!

Just create your account and start using Limesurvey today.

Register now